Can’t install new plugin on ubuntu …

I installed new ubuntu 11.10 and and configured my localhost ( php, mysql and phpmyadmin ) then a problem started to appear when i tried to run wordpress on my localhost
The problem is when I try to install a new theme or new plugin it doesn’t start installing but prompts me instead for:

Connection Information
To perform the requested action, WordPress needs to access to your web server. Please enter your FTP credentials to proceed. If you do not remember your credentials, you should contact your web host.
Hostname
FTP Username
FTP Password
Connection Type
Connection Type FTP FTPS (SSL)

To solve the problem you have to do the following:

  1. Make new file in the www directory
  2. nano index.php
    echo phpinfo();
    
  3. See the Apache2handler and look for the user/group –> what is the name of it ( mine was apache(#)/# ) the name of the user here is apache
  4. Change the owner of the apache
  5. sudo chown -R apache /var/www
    
  6. Change the premission of the of the directory
  7. sudo chmod -R /var/www
    
  8. restart apache
  9. sudo /etc/init.d/apache2 restart
    
Advertisements
Leave a comment

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: